Фотогалереи

Услуги

Помощь при использовании сайта

NFS-Utils и glibc-2.12

В Gentoo не так давно обновилась glibc до версии 2.12.2. В основном это обновление проблем мне не принесло, за исключением одного но. Перестал собираться пакет nfs-utils-1.1.4-r1 с примерно таким выхлопом:

exportfs.c:(.text+0x1be): undefined reference to `S_ISDIR'
exportfs.c:(.text+0x1cb): undefined reference to `S_ISREG'

Я использовал именно nfs-utils-1.1.4-r1 потому что при использовании любой другой версии этого пакета выше чем 1.1.4-r1 у меня отказывался стартовать демон nfs.

Погуглив немного по теме выяснилось, что проблема скорее всего в новом glibc, но откатываться обратно и пересобирать систему мне совсем не хотелось. В багзилле Gentoo было сообщение о том, что новые версии собираются нормально, что я и попробовал сделать.
Без проблем собрал nfs-utils-1.2.3-r1 который на мое удивление нормально заработал. Возможно проблема решилась благодаря тому, что используемое ядро сейчас - 2.6.39 или девелоперы поправили исходники.

0
Голосов пока нет
Ваша оценка: Нет