Фотогалереи

Услуги

Помощь при использовании сайта

Если установщик Mac OS X не видит жесткий диск

На многих форумах ниосиляторы плачутся что установщик Mac OS X не видит их жесткого диска, а местные "гуру" эникейщики несут всякую чушь типа загрузись с параметрами cpus=1 и прочую чушь что никак не влияет на это. Я тоже столкнулся с этой проблемой. Первое что нужно сделать это включить SATA в режим AHCI в BIOS. Второе убедиться что на HDD имеется хотя бы одна Primary partition, так как ни убогая венда, ни Лиопард ниасилили установку на логические разделы созданные в расширенном (extended). И третье что нужно сделать для того чтобы раздел нужный для установки определился нормально - это форматнуть его в HFS+. Например воспользовавшись прекрасным инструментом под названием SystemRescueCD. Который кстати может писать в эту файловую систему, так что для починки Хакинтоша сойдет. Если ваш Лио не загружается даже в single mode то загрузиться с флешки SystemRescueCD и его полным монтированием в RAM за 30 сек гораздо удобнее чем ждать 5 минут пока загрузится DVD с инсталлером.

4.166665
18 votes
Ваша оценка: Нет


Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".
Аватар пользователя anonymous

А если установщик уже при установке, не видит содержимое диска, и при этом диск записан хорошо уже и не два не три диска, а штук 15, но всеравно пишет что "Мультимедийный носитель поврежден".
В чем тут загвоздка? Подскажите пожалуйста.

Аватар пользователя admin

Немного непонятна суть вопроса. Сообщение выдается для установочного диска или для целевого? Если установка уже началась и никаких предупреждений не было, то я даже не знаю как быть. Перепроверьте контрольные суммы установочного образа или попробуйте записать образ на другом природе. В крайнем случае скачайте другую сборку хакинтоша.

Аватар пользователя anonymous

Да Вы верно поняли, установка начинается и доходя до половины обрывается сообщением "Мультимедийный носитель поврежден". Буду искать другие сборки, те сборки что я писал на диски, выложены 2009 года. Возможно они битые. Если у Вас есть информация о хорошей раздаче, поделитесь пожалуйста, буду очень признателен. А так спасибо Вам за варианты решения, буду искать и попробую записать с другого привода.

Аватар пользователя admin

Я в свое время ЕМНИП ставил iAtkos v2. Раздача жива на rutracker.org. Ещё torrentmac.ru могу посоветовать. За год (а именно столько времени прошло с того времени как я последний раз щупал макось)я думаю появилось множество других сборок. Установка хакинтоша всегда было занятием требующим немалых мистических навыков у пользователя ;)

Аватар пользователя anonymous

Спасибо огромное Вам за отзыв и помощь в этом не легком и загадочном бытие!) Желаю Вам всего самого лучшего!!! Обязательно воспользуюсь торентмаком, я о таком даже не знал)
И все таки Вы думаете что ошибка при установке "Мультимед. носитель поврежден" вызвана записью(приводом) или может быть дело в IDE ? Знаю что у мака есть конфликт с IDE но на каком уровне не знаю и до или после тоже не знаю)

Аватар пользователя admin

Я всё же склоняюсь к варианту, что виноват привод. Я свой хак нормально поставил с IDE привода. Мне это удалось потому, что в сборке (загрузочном образе) изначально были интегрированы кексты с поддержкой IDE. Без них даже загрузиться было бы невозможно, так как макось работает только с, SATA.
Я думаю, что в вашей сборке они тоже присутствуют. Почитайте описание сборки там где вы это качали и многое сразу прояснится.

Аватар пользователя anonymous

Те что я пробовал были без ИДЕ, но установщик загружался, и все работало, диск форматирую в журнальную ось икс, далее установка и на половине, сразу же почти после вычисления времени установки, пишет носитель поврежден. Могло быть такое не из за привода а из за отсутствия фиксов на ИДЕ? Потому что я ставил сборки 2008 -2009 года без фиксов на ИДЕ. Я просто не посмотрел год раздачи, и глаза вспыхнули и давай дико качать сборку за сборкой!) и так же писать, но писал всегда на самой маленькой скорости, в общем в таких делах все делаю по феншую. Попробую и привод другой и сборку нашол с фиксом на ИДЕ, попробую и ее, вдруг пойдет установка Оськи.

Аватар пользователя anonymous

Я вот читал что в биосе нужно включать Нативный режим, и еще что нужно отключать поддержку СпидСтэп, Вы об этом что нибудь знаете?
И огромное спасибо Вам что остаетесь на связи! Вы можно сказать уже открыли Мне америку, так как я не знал что на ИДЕ сборки без фиксов не ставятся, везде как размыто об этом пишут.

Аватар пользователя anonymous

И очень этим помогли!!! очень Вам признателен!!!
Проснусь и приступлю к делу!!!

Аватар пользователя admin

anonymous пишет:

Я вот читал что в биосе нужно включать Нативный режим, и еще что нужно отключать поддержку СпидСтэп, Вы об этом что нибудь знаете?
И огромное спасибо Вам что остаетесь на связи! Вы можно сказать уже открыли Мне америку, так как я не знал что на ИДЕ сборки без фиксов не ставятся, везде как размыто об этом пишут.

Да, я об этом писал в заметке по установке Mac OS X